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LAB 1-1 프로젝트 생성 실습(1/2)

Step 1-1-00. 구현도구 eclipse 를 실행한다.

C:\eGovFrame-3.10.0\eclipse (링크파일)

Step 1-1-01. eclipse 에서 eGovFrame>Start>New Web Project 메뉴를

선택한다.

Step 1-1-02.프로젝트 생성 위저드에서 아래와 같이 입력하고 Next 버튼을

클릭한다.

항목 입력내용 비고

Project name lab101 수동입력

Target Runtime <None> 자동입력

Dynamic Web
Module Version

2.5 자동입력

Group Id egovframe 수동입력

Artifact Id lab101 자동입력

Version 1.0.0 자동입력

Step 1-1-03. Generate Example 항목을 체크하고 Finish 버튼을 클릭하여

프로젝트를 생성한다.
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Step 1-1-04. 이클립스에서 생성된 프로젝트 우 클릭 > Run As >

Maven Install 을 클릭하여 Maven 을 실행한다.

Step 1-1-05. 데이터베이스를 설정을 확인한다.

( context-datasource.xml 설정 확인

<jdbc:embedded-database id="dataSource" type="HSQL">

<jdbc:script location= "classpath:/db/sampledb.sql"/>

</jdbc:embedded-database>

)

Step 1-1-06. 생성한 프로젝트를 실행하여 결과를 확인한다.

[Eclipse 이용]

lab101 우 클릭 > Run As > Run on Server 클릭 Finish 버튼 클릭

[오류발생시]

구현도구(eclipse) 재 기동, Maven Clean , Maven Install

실행 후 다시 Run On Server 실행

LAB 1-1 프로젝트 생성 실습(2/2)
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LAB 1-2 Code Generation 실습(1/5)

Step 1-2-01. lab102-code-generation프로젝트를오픈한다.

Step 1-2-02. Package Explorer에서생성된 lab102-code-generation의데이

터베이스를실행한다.

( DATABASE > db 마우스우클릭 StartExplorer > Start Shell Here선택, 커맨

드창에서 runHsqlDB.cmd실행)

* macOS및 Linux에서는 ./runHsqlDB.sh실행

Step 1-2-03. Data Source Explorer에서 HSQLDB에 Connect한다.

Step 1-2-04.이클립스 Window > Show View > Other…를선택하여 Show

View 창을연다.

프로젝트를선택한상태에서, 대화창에서 eGoveFramework >

eGovFrame Templates를더블클릭한다.
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LAB 1-2 Code Generation 실습(2/5)

Step 1-2-05. lab102-code-generation 프로젝트를 선택한 상

태에서 eGovFrame Templates 뷰에서 “ eGovFrame

Templates > CRUD > CRUD Program” 을 더블클릭 한

다.

Step 1-2-06. DB Info에서 HSQLDB를 선택하고,

PUBLIC > SAMPLE 테이블을 선택한 후 NEXT를 클릭한다.
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LAB 1-2 Code Generation 실습(3/5)

Step 1-2-07. 소스코드 자동생성 디렉토리 정보를 입력하고 Finish 버튼을 클릭한다.
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LAB 1-2 Code Generation 실습(4/5)

Step 1-2-08. [iBatis] src/main/resources 에서 egovframework.sqlmap.example 패키지의 sql-map-config.xml 파일을 열고

생성된 Sample_SQL.xml 파일을 추가되어 있는지 확인한다.

[MyBatis] src/main/resources 에서 egovframework.sqlmap.example 패키지의 mapper-config.xml 파일을 열고 생성된

Sample_MAPPER.xml 파일을 추가되어 있는지 확인한다.
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Step 1-2-09. 생성한 프로젝트를 실행한다.

[Eclipse 이용]

lab102-code-generation > Run As > Run on Server 클릭

Finish 버튼 클릭

[오류발생시]

Maven Clean , Maven Install 실행 후 다시 Run On Server 실행

Step 1-2-10. 웹브라우저를 통하여 생성한 소스의 기능을 확인한다.

[접속 URL]

http://localhost:8080/lab102-code-

generation/sample/SampleList.do

LAB 1-2 Code Generation 실습(5/5)
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LAB 1-3 테스트케이스 작성 및 수행 실습(1/2)

Step 1-1-01. 구현도구에서 File>Import.. 메뉴를 선택한다.

Step 1-1-02. Import wizard에서 General>Existing Projects into Workspace 를 선택한다.

Step 1-1-03. Import Projects에서 select archive file 항목을 선택하고 제공한 “egovgettingstarted.zip” 파일을 지정한다.

Step 1-4-04. lab103 > src/test/java > egovframework.guide.helloworld > HelloWorldServiceTest.java를 spring test를 활

용하여 다음과 같이 수정한다.

package egovframework.guide.helloworld;

import static org.junit.Assert.assertEquals;
import javax.annotation.Resource;

import org.junit.Test;
import org.junit.runner.RunWith;
import org.springframework.test.context.ContextConfiguration;
import org.springframework.test.context.junit4.SpringJUnit4ClassRunner;

@RunWith(SpringJUnit4ClassRunner.class)
@ContextConfiguration(locations={"/context-helloworld.xml"})

public class HelloWorldServiceTest {
private HelloWorldService helloworld;

@Resource(name="helloworld")
public void setHelloWorld(HelloWorldService hello) {
this.helloworld = hello;

}

@Test
public void SayHello() {
assertEquals( "Hello eGovFrame!!!", helloworld.sayHello() );

}
}
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LAB 1-3 테스트케이스 작성 및 수행 실습(2/2)

Step 1-4-05. 작성한 테스트 케이스를 실행하여 결과를 확인한다.

[ jUnit 이용 ]

lab103 > Run As > jUnit Test 실행

[ Maven 이용 ]

lab103 > Run As > Maven test 실행
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 Step 1-4-01 - Project 생성(1/4)

- 전제조건 : eGovFrame Perspective 실행(별첨1. eGovFrame Perspective 실행 참조)

- 방법1 : Eclipse Menu > eGovFrame > Start > New Web Project 선택

- 방법2 : Package Explorer > 마우스 오른쪽 버튼 클릭 > New > eGovFrame Web Project 선택

방법 1 방법2

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (1/11)

* 체크하지 않음

①

②

③
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 Step 1-4-01 - Project 생성(2/4)

- 프로젝트 정보 입력

* 프로젝트 생성 시 Generate Example 은 선택하지 않도록 한다.

(선택한 경우에는 Example에 해당하는 Table을 테스트DB에 생성 필요)

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (2/11)

항목 입력내용 비고

Project name lab104 수동입력

Target Runtime <None> 자동입력

Dynamic Web
Module Version

2.5 자동입력

Group Id egovframe 수동입력

Artifact Id lab104 자동입력

Version 1.0.0 자동입력
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 Step 1-4-01 - Project 생성(3/4)

- 프로젝트 생성 결과 확인

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (3/11)
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 Step 1-4-01 – Database Connection 생성(4/4)

- 실습용으로 배포된 MySql DB를 실행

실행방법 : mysql설치폴더(C:\eGovFrame-3.10.0\bin\mysql-5.6.21) > startup.bat 실행

종료방법 : mysql설치폴더(C:\eGovFrame-3.10.0\bin\mysql-5.6.21) > stop.bat 실행

- Eclipse Menu > Window >Show View > Data Source Explore

- (참조 : 04.[참고]개발환경_실습교재 별첨2. Database Connection 생성)

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (4/11)

항목 정보

Database com

username com

password com01

포트 3306
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 Step 1-4-01 – Database Connection 생성(4/4)

- Eclipse Menu > Window >Show View > Data Source Explore

- (참조 : 04.[참고]개발환경_실습교재 별첨2. Database Connection 생성)

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (4/11)

* DB에 접근 가능한지 클릭
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 Step 1-4-02 - 공통컴포넌트 생성 위저드 실행(1/5)

- 프로젝트 선택 마우스 우클릭> New > eGovFrame Common Component 선택

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (5/11)
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 Step 1-4-02 - 공통컴포넌트 생성 위저드 실행(2/5)

− 공통 컴포넌트 목록 중 “역할/권한관리” 및 “게시판”을 선택하고 [Next]를 클릭

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (6/11)
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 Step 1-4-02 - 공통컴포넌트 생성 위저드 실행(2/5)

− 선택한 컴포넌트를 확인하고 테이블 설치여부를 선택 (실습 예제로 “사용자 DB에 생성” 선택)

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (6/11)



20
Page l 20

 Step 1-4-02 - 공통컴포넌트 생성 위저드 실행(3/5)

− Data Source Explorer에 등록한 사용자의 DB 중 하나를 선택하고 Connection Test를 클릭

(별첨 2. Data Source Explorer 연결 방법 참조)

− Connection Test 이후에 활성화된 Create Table 버튼을 클릭

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (7/11)
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 Step 1-4-02 - 공통컴포넌트 생성 위저드 실행(4/5)

− Create Table을 정상적으로 완료한 후 Finish를 클릭

− web.xml 수정여부 “OK” 선택

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (8/11)
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 Step 1-4-02 - 공통컴포넌트 생성 위저드 실행(5/5)

− 생성된 소스 확인

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (9/11)

①

① 클릭후 메뉴에서 Package Presentation >
Hierarchical 선택하면 계층 구조로 볼수 있다.



23
Page l 23

LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (10/11)

 Step 1-4-03 - 생성된 공통컴포넌트 로그인

− 별첨3. 서버 설정 (Tomcat) 참조

* 위키가이드 참조
https://www.egovframe.go.kr/wiki/doku.php?id=egovfr
amework:com:v3.9:uat:%EC%9D%BC%EB%B0%98%EB
%A1%9C%EA%B7%B8%EC%9D%B8

구분 ID PW 비고

일반사용자 USER rhdxhd12 영문으로 공통12

기업사용자 ENTERPRISE rhdxhd12 영문으로 공통12

업무사용자 TEST1 rhdxhd12 영문으로 공통12

webmaster rhdxhd12 영문으로 공통12
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LAB 1-4 공통컴포넌트 생성 및 조립도구 실습 (11/11)

 Step 1-4-04 - 생성된 공통컴포넌트 확인

− 별첨3. 서버 설정 (Tomcat) 참조
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LAB 1-5 템플릿 프로젝트 생성 실습(1/3)

Step 1-5-01. 구현도구에서 eGovFrame>Start>New Template Project 메뉴를 선

택한다.

Step 1-5-02. eGovFrame Template Project 위저드에서 Simple Project를 선택한

다.

항목 입력내용 비고

Project name lab105 수동입력

Target Runtime <None> 자동입력

Dynamic Web
Module Version

2.5 자동입력

Group Id egovframe 수동입력

Artifact Id lab105 자동입력

Version 1.0.0 자동입력

Step 1-5-03. eGovFrame Template Project에서 아래와 같이 입력하고 Finish버튼을
클릭한다.
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Step 1-5-04. 이클립스에서 Run As > Maven Install 을 클릭하여 Maven 을 실행한다.

Step 1-5-05. 생성한 프로젝트를 실행하여 결과를 확인한다.

[Eclipse 이용]

lab105 > Run As > Run on Server 클릭

Finish 버튼 클릭

[오류발생시]

구현도구(eclipse) 재기동, Maven Clean , Maven Install 실행 후

다시 Run On Server 실행

LAB 1-5 템플릿 프로젝트 생성 실습(2/3)
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Step 1-5-06. 상단 [로그인] 버튼 클릭후 로그인 화면으로 이동한다.

Step 1-5-07. admin / 1 입력하여 로그인 한다.

LAB 1-5 템플릿 프로젝트 생성 실습(3/3)
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 DBIO 사용방법을 설치부터 활용까지 간략하게 훑어본다.

 실습 순서

1. DB실행

2. DBIO 실습

- eGovFrame Perspective 실행

- Project 생성

- SqlMapConfig 파일 생성

- SqlMap 파일 생성

- SqlMap 파일 편집

1. Parameter Map 작성

2. Result Map 작성

3. Query 작성

3. Query 테스트

LAB 1-6 DBIO 실습(iBatis)(1/20)
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제공된 Lab의 DATABASE의 db폴더에있는 runHsqlDB를실행하여 DB를실행

LAB 1-6 DBIO 실습(iBatis)(2/20)
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 eGovFrame Perspective 실행

− Eclipse Menu > Window > Open Perspective > eGovFrame

LAB 1-6 DBIO 실습(iBatis)(3/20)
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 Project 생성

− 방법1 : Eclipse Menu > eGovFrame > Start > New … 선택

− 방법2 : Package Explorer > 마우스 오른쪽 버튼 클릭 > New > eGovFrame … 선택

방법 1 방법2

실습예제로 eGovFrame Core Project 선택

LAB 1-6 DBIO 실습(iBatis)(4/20)
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.

LAB 1-6 DBIO 실습(iBatis)(5/20)

* 체크하지 않음
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− 결과

LAB 1-6 DBIO 실습(iBatis)(6/20)



34
Page l 34

 SqlMapConfig 파일생성

− 방법1 : Eclipse Menu > eGovFrame > Implementation > New Sql Map Config

− 방법2 : Package Explorer > 마우스오른쪽버튼클릭 > New > sqlMapConfig

방법 1 방법2

LAB 1-6 DBIO 실습(iBatis)(7/20)
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− 파일저장 folder 선택

− 파일명입력

− Finish 버튼클릭

LAB 1-6 DBIO 실습(iBatis)(8/20)
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− 결과화면(SqlMapConfig Editor)

LAB 1-6 DBIO 실습(iBatis)(9/20)
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 SqlMap 파일생성

− 방법1 : SqlMapConfig Editor > New 버튼 클릭 (파일생성과동시에 SQL Map 목록에추가)

− 방법2 : Package Explorer > 마우스오른쪽버튼클릭 > New > sqlMap

방법1 방법2

LAB 1-6 DBIO 실습(iBatis)(10/20)
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− 파일저장폴더선택

− 파일명입력

LAB 1-6 DBIO 실습(iBatis)(11/20)
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− 결과화면(SqlMap Editor)

LAB 1-6 DBIO 실습(iBatis)(12/20)
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 Parameter Map 작성

− SqlMap Editor > SqlMap Tree > ParameterMap Branch 선택 > 마우스오른쪽버튼 > Add parameterMap 메뉴

LAB 1-6 DBIO 실습(iBatis)(13/20)
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− ID 변경 : deptNo

− Class 선택 : java.lang.String

− 매개변수추가

①

②
③

④

LAB 1-6 DBIO 실습(iBatis)(14/20)

①, ④는 직접 입력 한다.
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 Result Map 작성

− SqlMap Editor > SqlMap Tree > ResultMap Branch 선택 > 마우스오른쪽버튼 > Add resultMap 메뉴

LAB 1-6 DBIO 실습(iBatis)(15/20)
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− ID 변경 : resultMap

− Class 선택 : java.lang.String

− 속성추가 : ( Property : deptName / Column : DEPT_NAME )

①, ④는 직접 입력 한다.

* Class 항목에 속성을 가진 Class
를 선택할 경우 [Set Property] 버
튼을 눌러 Property 테이블에 자동
으로 속성을 채운다.

①
②

③
④

LAB 1-6 DBIO 실습(iBatis)(16/20)
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 Query 작성

− SqlMap Editor > SqlMap Tree > Query Branch 선택 > 마우스오른쪽버튼 > Add Select Query 메뉴

LAB 1-6 DBIO 실습(iBatis)(17/20)
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- ID 변경 : selectDept

- Query 작성 :

DB Info : hsqlDB 선택

[Open Query Builder] – 쿼리생성 (SELECT * FROM PUBLIC.DEPT)

- Parameter 입력 : Map (deptNo)

- Result 입력 : Map (resultMap)

- Query Test

①

②

③

④

LAB 1-6 DBIO 실습(iBatis)(18/20)
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 Query 테스트

− DB 선택

− 바인딩변수설정

− 바인딩변수값입력

− 테스트실시

LAB 1-6 DBIO 실습(iBatis)(19/20)
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.

테스트 가능 Query 형태는 홈페이지
(http://www.egovframe.go.kr)의 개발
환경 가이드 참조①

②
③

결과확인

④
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 DBIO 사용방법을 설치부터 활용까지 간략하게 훑어본다.

 실습 순서

1. DB실행

2. DBIO 실습

- eGovFrame Perspective 실행

- Project 생성

- Mapper Configuration 파일 생성

- Mapper 파일 생성

- Mapper 파일 편집

1. Result Map 작성

2. Query 작성

3. Query 테스트
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제공된 Lab의 DATABASE의 db폴더에있는 runHsqlDB를실행하여 DB를실행
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 eGovFrame Perspective 실행

− Eclipse Menu > Window > Open Perspective > eGovFrame
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 Project 생성

− 방법1 : Eclipse Menu > eGovFrame > Start > New … 선택

− 방법2 : Package Explorer > 마우스 오른쪽 버튼 클릭 > New > eGovFrame … 선택

방법 1 방법2

실습예제로 eGovFrame Core Project 선택
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− 결과
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 Mapper Configuration 파일생성

− 방법1 : Eclipse Menu > eGovFrame > Implementation > New Mapper Configuration

− 방법2 : Package Explorer > 마우스오른쪽버튼클릭 > New > mapperConfiguration

방법 1 방법2
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− 파일저장 folder 선택

− 파일명입력

− Finish 버튼클릭
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− 결과화면(Mapper Configuration Editor)
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 Mapper 파일생성

− 방법1 : Mapper Configuration Editor > New 버튼 클릭 (파일생성과동시에 Mapper 목록에추가)

− 방법2 : Package Explorer > 마우스오른쪽버튼클릭 > New > mapper

방법1 방법2
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− 파일저장폴더선택

− 파일명입력
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− 결과화면(Mapper Editor)
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 Result Map 작성

− Mapper Editor > Mapper Tree > ResultMap Branch 선택 > 마우스오른쪽버튼 > Add resultMap 메뉴
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− ID 변경 : resultMap

− Type 선택 : java.lang.String

− 속성추가 : ( Property : deptName / Column : DEPT_NAME )

Type 항목에 속성을 가진 Class를
선택할 경우 [Set Property] 버튼
을 눌러 Property 테이블에 자동으
로 속성을 채운다.

①

②

③
④
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 Query 작성

− Mapper Editor > Mapper Tree > Query Branch 선택 > 마우스오른쪽버튼 > Add Select Query 메뉴
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- ID 변경 : selectDept

- Query 작성 :

DB Info : hsqlDB 선택

[Open Query Builder] – 쿼리생성 (SELECT * FROM PUBLIC.DEPT)

- Parameter 입력 : Type (java.lang.String)

- Result 입력 : Map (resultMap)

- Query Test

①

②

③

④
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 Query 테스트

− DB 선택

− 바인딩변수설정

− 바인딩변수값입력

− 테스트실시
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.

테스트 가능 Query 형태는 홈페이지
(http://www.egovframe.go.kr)의 개발
환경 가이드 참조

①

②

③

결과확인

④

LAB 1-7 DBIO 실습(MyBatis)(18/18)


